Home > Default > WL Server & apache 2 integration: mod_weblogic: could not create lock

WL Server & apache 2 integration: mod_weblogic: could not create lock

December 10Hits:4
Advertisement
Hi,
we're running Apache 2.0.50 as a front-end for WL Server 8.1 using mod_weblogic as the proxy.
We have to run Apache as a different user than the default LocalSystem account to be able to access a windows share. But when we set up Apache to run as a user (in the windows domain) the server will not start up. Looking at the error log I can see the following message:
[Wed Jan 26 16:10:37 2005] [crit] (OS 5)Access is denied. : mod_weblogic: could not create lock
The user has administrative rights on the server so I'm not really sure why mod_weblogic can not obtain a lock.
What is the lock it's trying to obtain?
Thanks.
Ruairi

Answers

Hello,
has this been resolved by anyone in the meantime? I'm running into the same kind of problem. Here's my setup:
Apache 2.0.55, on Solaris 8
mod_wl_20.so, from Bea Weblogic Server 8.1 SP 2
When I have the following line in my httpd.conf file:
LoadModule weblogic_module modules/mod_wl_20.so
I receive the following error in Apache's error log file:
[timestamp] [crit] (13)Permission denied: mod_weblogic: could not create lock
I am currently not running Apache as root. Without the weblogic module, it works fine.
I guess my main question is: what kind of lock is it trying to obtain? Changing the AcceptMutex parameter in Apache does not seem to help.
Regards,
Ralf

Read other 8 answers

Tags:

Related Articles

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 14 q. 0.781 s.