Home > Default > Wireless toolkit in sun one studio 4 update 1 mobile edition?

Wireless toolkit in sun one studio 4 update 1 mobile edition?

October 11Hits:0
Advertisement
I'm starting work on a MIDP 2.0 procect that requires the 2.1 wireless toolkit for JSR-172 (web services) support. I'm currently using Sun One Studio 4 update 1Mmobile Edition with the built-in 1.04 toolkit. Is there any way for me to setup the 2.1 toolkit to work with S1ME4_1?
I know the Early Access release of ME 5 ships with 2.1 toolkit support, but my project extends beyond the 60 day license.
Any help would be appreciated. Thanks. :-)

Answers

Hi,
1. install the WTK 2.1
2. In your project in S1ME4_1 in the Explorer
- select Runtime -> Device Emulator Registry -> Installed Emulators
- click right on that and choose "Add... Emulator" and enter your path to the WTK 2.1 (normally you have then a new "installed emulator" (J2ME WTK2.1)
3. Open the "Default Emulator" and change it by clicking right on the one mentioned.
4. add the midpapi20.jar from the lib directory of WTK2.1 to the classpath (i.e. by mounting)
Hope it works.
Kay

Read other 3 answers

Tags:

Related Articles

  • Wireless toolkit in sun one studio 4 update 1 mobile edition?October 11

    I'm starting work on a MIDP 2.0 procect that requires the 2.1 wireless toolkit for JSR-172 (web services) support. I'm currently using Sun One Studio 4 update 1Mmobile Edition with the built-in 1.04 toolkit. Is there any way for me to setup the 2.1 t

  • Problem installing Sun ONE Studio 4 update 1, Community EditionNovember 30

    I recently downloaded the Sun ONE Studio 4 update 1, Community Edition and tried to install it. At one point it searches for a valid JAVA 2 SDK. This seems to go on forever. I quit after 5 hours of waiting. I already have Java 2 standard edition v1.4

  • Using JMF API with Sun One Studio v4 update 1 (community ed.)October 11

    Having great difficulty trying to utilise the JMF API I've just downloaded with Sun One Studio v4, update 1 (community edition). After installing the API, I tried copying the the .jar files under the lib folder of JMF to the lib folder of sun one stu

  • Sun ONE Studio 4 Update 1 does not allow to deploy a moduleOctober 11

    I have created CMP entity beans based on a database schema captured using the jdbcodbc driver.Each one with its primary key and correctly validate. Then I have created a module and added to the module all CMP beans. Then when I attempt to deploy the

  • JATO 2.0 Licensing for Sun ONE Studio 4 Update 1 EEOctober 11

    I have a serial number for Sun ONE Studio 4 EE which I'm also able to use for Sun ONE Studio 4 Update 1 EE. I downloaded JATO 2.0 as offered in the Studio Update Center. It asked for a serial number so I tried my Studio serial number but it didn't wo

  • Fail to run my first Servlet with Sun ONE Studio 4 Update 1 (+ bi Tomcat)November 30

    Hello ! I failed to run my first Servlet with Sun ONE Studio 4 update 1 ( with built in Tomcat) I think that I followed most of the online instructions, so I successfully run a JSP file, but I failed with my first servlet: The error message is: "Stan

  • Sun ONE Studio 4 update 1, CE CrashesNovember 30

    I know this is off-topic but I didn't see any forums related to the Sun ONE IDE. The IDE crashes every time I right click on a folder in the filesystem explorer and select New -> Classes (mainly the only one I use...of course). Everything else seems

  • Sun One Studio 5 Update 1 + Sun One Application Server 8November 30

    I haven't been able to setup Sun One Studio 5 to work with Sun One Application Server 8. I already tried with the plugin for netbeans 3.6, but it fails on dependencies. The plugin and dependencies can not be found on the update center. I'd appreciate

  • Sun ONE Studio 4 update 1November 30

    Hi, i am new with J2Me. I have some experience with "normale" Java, JSP and Servlet technology. Now i want to build an application for Handys. I downloaded the Toolkit and build some of the demo Apps. Now my question: Wich IDE is good for J2ME?

  • Sun one studio 4 update 1 installation problems with windows meOctober 11

    Hi guys! I tried installing the cobundle on a Windows ME platform and it always get stuck whenever the progress bar is at 99%. When I try doing the long method (install JDK and then the IDE), installing the JDK is fine but the installation of the IDE

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 14 q. 0.685 s.