Home > Default > Virgo Tools for Eclipse Luna and Mars

Virgo Tools for Eclipse Luna and Mars

October 11Hits:5
Advertisement
Hi all,
I tried to install the Virgo Tools both in Eclipse Luna and in Mars (JEE packages), from this update site:
"Virgo IDE Releases" - http://download.eclipse.org/virgo/release/tooling
- Eclipse Virgo Tools 1.0.1.201302270038-RELEASE
but I got errors (see below).
Instead all il working well with Kepler.
Some suggestions?
Thank you very much.
Vincenzo
================================================
Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse Virgo Tools 1.0.1.201302270038-RELEASE (org.eclipse.virgo.ide.feature.feature.group 1.0.1.201302270038-RELEASE)
Software currently installed: Eclipse IDE for Java EE Developers 4.5.0.20150621-1200 (epp.package.jee 4.5.0.20150621-1200)
Only one of the following can be installed at once:
OSGi System Bundle 3.8.1.v20120830-144521 (org.eclipse.osgi 3.8.1.v20120830-144521)
OSGi System Bundle 3.10.100.v20150529-1857 (org.eclipse.osgi 3.10.100.v20150529-1857)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 4.5.0.20150621-1200 (epp.package.jee 4.5.0.20150621-1200)
To: org.eclipse.epp.package.jee.feature.feature.group
Cannot satisfy dependency:
From: EPP Java EE IDE Feature 4.5.0.20150621-1200 (org.eclipse.epp.package.jee.feature.feature.group 4.5.0.20150621-1200)
To: org.eclipse.m2e.feature.feature.group 0.0.0
Cannot satisfy dependency:
From: Maven Integration for Eclipse 1.6.0.20150526-2032 (org.eclipse.m2e.core 1.6.0.20150526-2032)
To: bundle org.eclipse.osgi 3.10.0
Cannot satisfy dependency:
From: m2e - Maven Integration for Eclipse (includes Incubating components) 1.6.0.20150526-2032 (org.eclipse.m2e.feature.feature.group 1.6.0.20150526-2032)
To: org.eclipse.m2e.core
Cannot satisfy dependency:
From: Eclipse Virgo Tools 1.0.1.201302270038-RELEASE (org.eclipse.virgo.ide.feature.feature.group 1.0.1.201302270038-RELEASE)
To: org.eclipse.virgo.ide.manifest.core [1.0.1.201302270038-RELEASE]
Cannot satisfy dependency:
From: Eclipse Virgo IDE (Manifest Core) 1.0.1.201302270038-RELEASE (org.eclipse.virgo.ide.manifest.core 1.0.1.201302270038-RELEASE)
To: bundle org.eclipse.virgo.kernel.artifact 0.0.0
Cannot satisfy dependency:
From: Virgo Kernel Artifact Integration 3.6.0.RELEASE (org.eclipse.virgo.kernel.artifact 3.6.0.RELEASE)
To: package org.eclipse.virgo.nano.serviceability [3.6.0,3.7.0)
Cannot satisfy dependency:
From: Virgo Nano Core 3.6.0.RELEASE (org.eclipse.virgo.nano.core 3.6.0.RELEASE)
To: package org.eclipse.osgi.internal.baseadaptor 0.0.0

Answers

Sorry, I have to correct myself: today I retried with a brand new Mars/JEE+Java8 and a brand new workspace:
the error is related to missing org.json bundle.
Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse Virgo Tools 1.0.1.201506260038-SNAPSHOT (org.eclipse.virgo.ide.feature.feature.group 1.0.1.201506260038-SNAPSHOT)
Missing requirement: Eclipse Virgo IDE (Server Core) 1.0.1.201506260038-SNAPSHOT (org.eclipse.virgo.ide.runtime.core 1.0.1.201506260038-SNAPSHOT) requires 'bundle org.json 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Eclipse Virgo Tools 1.0.1.201506260038-SNAPSHOT (org.eclipse.virgo.ide.feature.feature.group 1.0.1.201506260038-SNAPSHOT)
To: org.eclipse.virgo.ide.runtime.core [1.0.1.201506260038-SNAPSHOT]
seems like Mars/JEE doesn't contain org.json ... which is quite strange ...
With Mars/JEE+Java7 instead the detailed error is:
Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse Virgo Tools 1.0.1.201506260038-SNAPSHOT (org.eclipse.virgo.ide.feature.feature.group 1.0.1.201506260038-SNAPSHOT)
Missing requirement: OSGi Framework Editor UI (Incubation) 0.2.0.201206060754 (org.eclipse.libra.framework.editor.ui 0.2.0.201206060754) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
Missing requirement: OSGi Framework Editor UI (Incubation) 0.3.0.201212132137 (org.eclipse.libra.framework.editor.ui 0.3.0.201212132137) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
Missing requirement: OSGi Framework Editor UI (Incubation) 0.3.0.201305070844 (org.eclipse.libra.framework.editor.ui 0.3.0.201305070844) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
Missing requirement: OSGi Framework Editor UI (Incubation) 0.3.0.201305151323 (org.eclipse.libra.framework.editor.ui 0.3.0.201305151323) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
Missing requirement: OSGi Framework Editor UI (Incubation) 0.3.0.201305311343 (org.eclipse.libra.framework.editor.ui 0.3.0.201305311343) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
Missing requirement: OSGi Framework Editor UI (Incubation) 0.3.1.201405141436 (org.eclipse.libra.framework.editor.ui 0.3.1.201405141436) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
Cannot satisfy dependency:
From: Eclipse Virgo Tools 1.0.1.201506260038-SNAPSHOT (org.eclipse.virgo.ide.feature.feature.group 1.0.1.201506260038-SNAPSHOT)
To: org.eclipse.virgo.ide.runtime.ui [1.0.1.201506260038-SNAPSHOT]
Cannot satisfy dependency:
From: Eclipse Virgo IDE (Server UI) 1.0.1.201506260038-SNAPSHOT (org.eclipse.virgo.ide.runtime.ui 1.0.1.201506260038-SNAPSHOT)
To: bundle org.eclipse.libra.framework.editor.ui 0.0.0
With Luna/JEE SR2 instead all is working well, both with Java7 and Java8
Vincenzo

Read other 9 answers

Tags:

Related Articles

  • Virgo Tools for Eclipse Luna and MarsOctober 11

    Hi all, I tried to install the Virgo Tools both in Eclipse Luna and in Mars (JEE packages), from this update site: "Virgo IDE Releases" - http://download.eclipse.org/virgo/release/tooling - Eclipse Virgo Tools 1.0.1.201302270038-RELEASE but I go

  • Dependency conflicts when installing WebLogic Server Tools in Eclipse JunoNovember 30

    Installing the WebLogic Server Tools in Eclipse (Juno) on Windows 7, 64 bit cannot be completed. Eclipse is up to date and several other plugins are installed. When installing the server tools, either via the Marketplace or the Server view -> New Ser

  • Getting error while installing sap hana development plugin in eclipse lunaNovember 30

    Hi Friends,    I am new to sap. I am trying to install sap Hana development plugin in my eclipse luna but  getting error in the middle of installation, that I have mentioned below. Can any one help me on this to get resolve. I am using eclipse luna(3

  • How to use Flash Builder  for Eclipse Luna ( is it possible??)November 30

    How to use Flash Builder  for Eclipse Luna ( is it possible??)Yes. I have Flash Builder 4.6 and 4.7 running in different Eclipse Luna installs. More details at http://forums.adobe.com/message/4527443 On Mac, I had to have the 32bit version of Luna fo

  • Plug a Swing-based development tool into EclipseOctober 11

    This article teaches you how to integrate a stand-alone Swing-based editor into the Eclipse Platform as a plug-in. Using simple techniques, you can share resources between the Swing tool, the Eclipse Platform, and various SWT widgets -- and these res

  • Troubles while migrate Eclipse Luna projects from 32 bit to 64 bitNovember 30

    Hello friends, could you help me to fix a problem? I worked on Eclipse Luna until recently and all my e4 projects worked well under Linux x86 (JDK7 and Eclipse were by 32 arch too). Now I migrate to a newer computer with Linux 64 bit. I install both

  • ATG development tools in EclipseNovember 30

    Hi, Need information on where to find the ATG Development tools for eclipse. Below chapter refers to non-existent url (http://www.atg.com/eclipse) http://docs.oracle.com/cd/E23095_01/Platform.93/ATGInstallGuide/html/s0108installingatgdevelopmenttools

  • Problem with Plugin Installation of SAP widget Developement tool in EclipseNovember 30

    Dear All I am faceing problem while installation of SAP widget Developement tools in Eclipse. Please help me Out. I have Downloaded Eclipse and also SAP Widget Developement tools.zip When I try to Install the Plugin for SAP Widget developement I get

  • Where can I find the Eclipse CEP tool for Eclipse 3.6?November 30

    Hi, I looked at the site and could find only the tool for Eclipse 3.5. Where can I find the Eclipse CEP tool for Eclipse 3.6? (http://download.oracle.com/technology/software/cep-ide/11/) Thanks, Shimon Edited by: 884793 on Dec 5, 2011 4:10 PMCorrect.

  • How to get Ant option under windows- Preferences in Eclipse Luna?November 30

    Hello Eclipse Support, I switched from Eclipse Kepler(windows 64-bit) to Eclipse Luna(eclipse-cpp-luna-SR2-win32-x86_64.zip) and I see that Ant option is missing under windows->Preferences. I tried this way: I saw there was an Apache ant(eclipse\plug

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 14 q. 0.581 s.