Home > Default > Unsupported major.minor version  exception in 10g IAS

Unsupported major.minor version  exception in 10g IAS

October 11Hits:0
Advertisement
I have developed a simple web-app based on JSF/MyFaces. In it I have included a managed bean. Upon deploying and running this web-app to Oracle 10g AS I get the following exception:
javax.faces.FacesException: uk/ac/ukbiobank/crms/infobean (Unsupported major.minor version 49.0)     at org.apache.myfaces.context.servlet.ServletExternalContextImpl.dispatch(ServletExternalContextImpl.java:421)     at org.apache.myfaces.application.jsp.JspViewHandlerImpl.renderView(JspViewHandlerImpl.java:234)     at org.apache.myfaces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:352)     at javax.faces.webapp.FacesServlet.service(FacesServlet.java:107)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:65)     at org.apache.myfaces.component.html.util.ExtensionsFilter.doFilter(ExtensionsFilter.java:122)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:663)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:330)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:830)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:224)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:133)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192)     at java.lang.Thread.run(Thread.java:534)Caused by: javax.servlet.ServletException: uk/ac/ukbiobank/crms/infobean (Unsupported major.minor version 49.0)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.EvermindPageContext.handlePageThrowable(EvermindPageContext.java:595)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.EvermindPageContext.handlePageException(EvermindPageContext.java:537)     at helloWorld.jspService(_helloWorld.java:164)     [SRC:/helloWorld.jsp]     at com.orionserver[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].http.OrionHttpJspPage.service(OrionHttpJspPage.java:56)     at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java:350)     at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java:509)     at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java:413)     at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:824)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:330)     at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.ServletRequestDispatcher.forward(ServletRequestDispatcher.java:253)     at org.apache.myfaces.context.servlet.ServletExternalContextImpl.dispatch(ServletExternalContextImpl.java:415)     ... 12 more
I assumed that it was due to the java-compiler pointing at the wrong JDK so I made the necessary changes to the server.xml. However, this has not made ant difference.
Has anybody else encountered this problem, and if so how did they fix it?
Thanks in advance for any help.
Angus

Answers

I guess you have windows, and the environment path you can set through dialog of system settings. Right click 'my computer' and choose properties. Find the button for environment settings. Somewhere here you will see Oracle has added som reference to the 1.3 version. Adjust this so it works.
Or, you can run the actual correct verssion of Java you would like from the commandline.
Instead of running:
c:\>java <Program name>try running by spesifying the correct java.exe path:
C:\>c:\program files\java\jre 1.6.0_07\bin\java.exe <program name>Hope this will help
- Roy

Read other 7 answers

Tags:

Related Articles

  • Unsupported major.minor version  exception in 10g IASOctober 11

    I have developed a simple web-app based on JSF/MyFaces. In it I have included a managed bean. Upon deploying and running this web-app to Oracle 10g AS I get the following exception: javax.faces.FacesException: uk/ac/ukbiobank/crms/infobean (Unsupport

  • Error while installing Service Manager 4.1 (Unsupported major.minor version)November 30

    Hi All, I have installed SMP 3.0 and I am installing Service Manager 4.1 on this server. I am folliwng the document - CRMSM41_Installation for installation of SM 4.1 After installation , I configured the JavaBE.ini file and Agentry.ini. . This is the

  • Error (Unsupported major.minor version 49.0) in Servlet - Tomcat 5.0.19November 30

    Hello, I am completely new to developing java web applications and I dealing with some very strange behavior. I am simply trying to run tomcat through a tomcat plugin for debugging purposes. When I start tomcat via the command line my application run

  • Different JDK problems: Unsupported major minor versionNovember 30

    We have a very large application, with a client that runs on a PDA and a client (and server) that will run on a normal desktop computer... These clients use partially the same code, and partially specific code. For the PDA-client we're bound to Creme

  • Error (Unsupported major.minor version 49.0)  in Servlet - Tomcat 4.1November 30

    Hello, I have got below error when i have run web application with JSP,Servlet,beans: I have used Tomacat 4.1, 5.0 and 5.9.No change ??? I am using j2sdk1.4.2_03 and j2re1.4.2_03. This is the complete project i want to run in my PC when i extract .wa

  • Packaging Wizard - Compile Jsp ! unsupported major.minor.versionNovember 30

    Hi! I did follow the "Building Offline Mobile Web Applications Using BC4J" Tutorial http://download-uk.oracle.com/docs/cd/B19188_01/doc/B15920/nvbc4jtu.htm#CACHIGCG using jdev904. Everything goes straight until I reach 20.3.5 I can't compile the

  • ODI to MSSQL - Unsupported major.minor versionNovember 30

    I have created my MSSQL Dataserver, and the connection tests good, but I am unable to create a Physical Schema. When I try I get the follow error(s) java.lang.UnsupportedClassVersionError: com/microsoft/sqlserver/jdbc/SQLServerDriver (Unsupported maj

  • UnsupportedClassVersionError Unsupported major minor version 50.November 30

    I installed Java 1.6 in C:\Program Files\Java\jdk1.6.0. I am able to compile a java files from the command prompt but when I try to run a java file I get the following error "UnsupportedClassVersionError Unsupported major minor version 50." I am

  • Jdbc tutorial Unsupported major.minor version 51.0November 30

    i am trying tolearn from this tutorial: [http://download.oracle.com/javase/tutorial/jdbc/basics/gettingstarted.html|http://download.oracle.com/javase/tutorial/jdbc/basics/gettingstarted.html] i did evrything up to 11. step (please read it) when i try

  • Exception in thread "main" Unsupported major.minor version 50.0November 30

    When i type javac <program name>.java it compiles. But when i type java <program name> i get this error: Exception in thread "main" java.lang.UnsupportedClassVersionError <Unsupportedmajor.minor version 50.0> I type javac -vers

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 14 q. 1.523 s.