Home > Default > Problems in Instantiating the Model Node

Problems in Instantiating the Model Node

October 11Hits:0
Advertisement
Hi All,
I Have a problem with creating the instance of a Model Node  which needs an urgent solution, This is the Scenario:
I Have created a WebDynpro Project using NetWeaver CE Environment and Java EE 5.0 where i am using an Adaptive WebService Model. I have successfully created the model using the WSDL files and have also added to the Controller,
But when I try to create an Instance of the Request Node in my controller ie after writing this line:
Request_MI_Nwce007_AS_SOAPReq objReq = null;
objReq = new Request_MI_Nwce007_AS_SOAPReq();
This is the Request Structure from the WSDL - Request_MI_Nwce007_AS_SOAPReq
it gives me an Error saying The constructor Request_MI_Nwce007_AS_SOAPReq() is undefined.
Please let me know the exact problem and also the way to overcome this problem.
Its Quite URGENT!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Points Rewarded for helpful answers.
Regards,
Poojith MV

Answers

Hi Poojitha,
If your imported Webservice has any structure like  this Request_MI_Nwce007_AS_SOAPReq_Input then instantiate the input structure.
else
Try instantiating along with the package name, for example if your package name is: com.sdn then try this:
"com.sdn.*Request_MI_Nwce007_AS_SOAPReq objReq = null;
objReq = new com.sdn.Request_MI_Nwce007_AS_SOAPReq();
Hope this solves your problem.
Thanks n Regards,
Jhansi Miryala

Read other 4 answers

Tags:

Related Articles

  • Problems in Instantiating the Model NodeOctober 11

    Hi All, I Have a problem with creating the instance of a Model Node  which needs an urgent solution, This is the Scenario: I Have created a WebDynpro Project using NetWeaver CE Environment and Java EE 5.0 where i am using an Adaptive WebService Model

  • Problem while copying from model node to value node!!November 30

    Hi All, I am trying to copy the contents of model table to newly created value table. For this i have written following code - IWDNode targetnode = wdContext.nodeZhress_Firstday_Service_ValueNode(); IWDNode sourcenode = wdContext.nodeOutput().nodeT_Z

  • Creation of new element in Model NodeOctober 11

    Dear All, I am facing one problem, I have two  model node. I want to copy one model node to other model node.while copying its giving error saying the you can bind the element, coz target node doesn't have valid parent. Pl don't suggest me work on Va

  • Instantiating Model Node in Component Controller with new Abstractlist()November 30

    Hi All, We have the following issue. When we instantiate a Node - Po_Items using Element.setPo_Items( new AbstractList() ) We get an error "The Type AbstractList Cannot be instantiate" . So how to successfully instantiate AbstractList()  so that

  • Problem in mapping model node with cardinalityOctober 11

    Hi, I have a requirement where the RFC  which is being called has cradinality 0..n. I imported the RFC model in a different DC and then added the model to public part. Then, I used that model in the second dc. Now, I did context mapping with the comp

  • Need help to read model node input field attribute present in view - first time developer.October 11

    Hello Experts, I am new to CRM Web UI development. Presently, I am trying to develop a Guided Activity Page having 2 views. First view has the field Business Partner Number, I have added model Node BuilHeader and the attribute BP_NUMBER while creatio

  • How to bindi a UI element to 2 model nodes different in the same viewOctober 11

    I want to know how I can bind a set of inputfields, in a form view, to 2 different model nodes ? <u>example:</u> Im working with 2 adaptional RFC, both working, in my Custom Context. Ztest_Search Ztest_Update In my ResultView I have 2 Model no

  • Java.lang.NullPointerException in RFC model nodeOctober 11

    Hi All, I am calling one of RFC from CRM system but getting some NullPointerException in model node. Details: 1. creating input node 2. pass parameter and bind input node 3. execute node 4. invalidate output node I am getting this exception when I ac

  • How to Transper data Model Node to Vallue NodeNovember 30

    Hi Friends I am getting problem in Create the Check box in Table I am getting model node from ECC System(Zmmoa_Pending_Getlist_Input) This is path for attributes avaliable Zmmoa_Pending_Getlist_Input-Output-outtab  Under outtab  all attributes avai

  • Force use of Model NodeNovember 30

    Hello All, I was wondering whether there is a way to force users to become a model node in a given environment rather than give them the choice of specifying model node or an individual node name. What happens is that our developers, all on the same

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 14 q. 0.612 s.