Home > Default > LabView Exe Applicatio​n file not launch Excel applicatio​n for report generation

LabView Exe Applicatio​n file not launch Excel applicatio​n for report generation

October 11Hits:5
Advertisement
Dear All,
I created one LabVIEW application file for report generation (using Excel Template).
While I run the program in programming mode it works well and create the report file in the specified path.
After creation of the application file(exe), it gives the correct path of where the excel template is placed. The same path is given to New Report.vi, but it gives the error 'File Not Found'.
Tell me, is any other configuration required for generating Excel reports? (During exe application mode)
Give me the solution.
Thank You
Jegan.

Answers

Hello,
Most likely you are encountering a problem of stripping and/or building paths.  Probably the easiest thing to do is put a couple indicators on your front panel for the path or paths you care about, build your exe, and make sure you are really using the path you'd like.  If you always put the report at some deterministic place relative to the exe (that is, even it the exe is moved, it will go with the exe and remain in the same relative path location, then you can use the Current VIs Path funtion found in the ... File I/O -> File Constants palette as a start path (where you will want to strip at least the exe name off of course).
I think this will bring some clarity to the issue!
Best Regards,
JLS
Best,
JLS
Sixclear

Read other 7 answers

Tags:

Related Articles

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 14 q. 1.013 s.