Home > Default > Help with Apache plugin for WebLogic on HP-UX

Help with Apache plugin for WebLogic on HP-UX

December 10Hits:3
Advertisement
Hi,
I am trying to get Weblogic 5.1(w/sp8) on HP-UX 11 talking to Apache 1.3.19.21(port
8080) also on HP-UX 11 ( both on same box ). I have WebLogic listening on port
9001, and I followed the instructions to configure apache and weblogic. However
when I do http://mymachine:8080/weblogic/portal/hello.jsp. I get unable to find
page.
weblogic is installed in /weblogic. The hello.jsp is located in /weblogic/myserver/public_html/portal/hello.jsp.
Apache is installed in /opt/apache.
The Apache httpd.conf file contains the following:
<Location /weblogic>
SetHandler weblogic-handler
PathTrim /weblogic
WebLogicHost localhost
WebLogicPort 9001
</Location>
What am I missing ? The error_log for Apache shows the following:
[Mon Nov 12 11:21:09 2001] [warn] Loaded DSO libexec/mod_wl.so uses plain Apache
1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
[Mon Nov 12 11:21:10 2001] [notice] Apache/1.3.19 (Unix) PHP/4.0.4pl1 configured
-- resuming normal operations
[Mon Nov 12 11:21:32 2001] [notice] child pid 13248 exit signal Segmentation fau
lt (11)

Answers

Well... there is a warning in the log file saying that it might crash - and then
it crashes. Check that you are running a supported platform, if you are, contact
BEA Support.
I would discourage the use of forwarding to 'localhost'.
Mike
"Niranjan Perera" mckesson.com wrote:
>
Hi,
I am trying to get Weblogic 5.1(w/sp8) on HP-UX 11 talking to Apache
1.3.19.21(port
8080) also on HP-UX 11 ( both on same box ). I have WebLogic listening
on port
9001, and I followed the instructions to configure apache and weblogic.
However
when I do http://mymachine:8080/weblogic/portal/hello.jsp. I get unable
to find
page.
weblogic is installed in /weblogic. The hello.jsp is located in /weblogic/myserver/public_html/portal/hello.jsp.
Apache is installed in /opt/apache.
The Apache httpd.conf file contains the following:
<Location /weblogic>
SetHandler weblogic-handler
PathTrim /weblogic
WebLogicHost localhost
WebLogicPort 9001
</Location>
What am I missing ? The error_log for Apache shows the following:
[Mon Nov 12 11:21:09 2001] [warn] Loaded DSO libexec/mod_wl.so uses plain
Apache
1.3 API, this module might crash under EAPI! (please recompile it with
-DEAPI)
[Mon Nov 12 11:21:10 2001] [notice] Apache/1.3.19 (Unix) PHP/4.0.4pl1
configured
-- resuming normal operations
[Mon Nov 12 11:21:32 2001] [notice] child pid 13248 exit signal Segmentation
fau
lt (11)

Read other 2 answers

Tags:

Related Articles

  • Setup issues: Apache plugin for WeblogicOctober 11

    Hi, I've spent couple of days without success trying to configure apache plugin for weblogic. I've configured in accordance with bea documentation and it works fine in windows environment but fails in Solaris 9. Plugin log file says it's processed th

  • Apache plugin for WebLogic 8.1November 30

    I tried to find the Apache plugin for WebLogic 8.1, but I could not find one. I downloaded the one from BEA web site, but it did not work. I run Apache 2.0.46 on Windows 2000 and WebLogic 8.1. The plugin I downloaded gave an error message complaining

  • JMX with apache plugin and weblogicOctober 11

    Hy every body I use weblogic 9.1, throw apache plugin I try to get mbean with JMX, i have this error on the log of the server when I try to acces to a server by passing apache url into jmxConnector: java.lang.AssertionError: Assertion violated      a

  • Netscape or Apache plugin for WebLogicNovember 30

    Hi, The Netscape plugin for WebLogic is mentioned many time in on-line documents for WebLogic servers. However, I can't find any information with regard to how the plug-in is distributed, licensed. Could someone please tell me if it is bundled in the

  • Apache plugin for Weblogic not forwarding entire X509 certificate chainNovember 30

    I really hope there's someone out there that can help with this. I've spent all week trying various things to make this work. SUMMARY It doesn't appear that the Weblogic plugin (mod_wl_20.so) for Apache (2.0.49) sends the entire X509 certificate chai

  • Help with Apache plugin for WebLogic on HP-UXDecember 10

    Hi, I am trying to get Weblogic 5.1(w/sp8) on HP-UX 11 talking to Apache 1.3.19.21(port 8080) also on HP-UX 11 ( both on same box ). I have WebLogic listening on port 9001, and I followed the instructions to configure apache and weblogic. However whe

  • Weblogic access.log when using apache pluginNovember 30

    Hello, If I use the apache plugin with weblogic, what will be the IP address in access.log of weblogic ? Will they only be apache's IP ? Regards, DomIs it possible that Apache itself is doing some url rewriting? I would suggest turning on debugging a

  • Apache frontend for Weblogic: problemNovember 30

    Folks, I have Apache 2.x running. The module "mod_wl_20.so" is in the <apache_home>/modules directory. httpd.conf contains the following: LoadModule weblogic_module modules/mod_wl_20.so <IfModule weblogic_module> WebLogicHost <ip-

  • Apache plugin - CookiesNovember 30

              Hi. We are trying to set up Apache plugin with WebLogic servers in a cluster. Before           even getting to clustering, I was just trying to proxy requests to one WebLogic Server           from the Apache server . I am able to get to the

  • WLS5.1 apache plugin for Solaris8 IntelNovember 30

    Is there WLS5.1 apache plugin for Solaris8 Intel platform?Which platform? WebLogic 8.1 does package the plugin. Look in either in the weblogic81\server\lib\XXXXX directory or in the weblogic81\server\bin directory for the mod_wl_20.so. Eric "Alan Won

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 14 q. 0.402 s.