Home > Default > Help with apache mod_perl

Help with apache mod_perl

December 10Hits:6
Advertisement
I'm in the process of teaching myself perl, and I've also just set up a server. I'd like to combine my efforts .    I'd like to know how to set up apache with mod_perl. I gather it will probably need some sort of recompilation? I also don't see a mod_perl package anywhare. What will I have to do to set this up?
I've been using linux for a while, and arch for most of the time, but I've never really played with this sort of thing before, so I'm kinda lost  :oops: .

Answers

Dirty PKGBUILD, which doesn't work. Oh well, I'll repair it ASAp
# $Id$
pkgname=mod_perl
pkgver=2.0
pkgrel=1
pkgdesc="The full power of the Perl programming language and the Apache HTTP server."
url="http://perl.apache.org"
depends=(apache perl)
source=(mod_perl-2.0-current.tar.gz)
md5sums=('3e7f7aefb19c772a998802990ced15c0')
build() {
cd $startdir/src/$pkgname-2.0.0-RC6
perl Makefile.PL MP_APXS=`which apxs` PERLPREFIX=$startdir/pkg/usr SITEPREFIX=$startdir/pkg/usr
make || return 1
make install
Maybe somebody will write tidier package. Take care. (Well, next would be embperl package).
Ja ne,
Antti

Read other 2 answers

Tags:

Related Articles

  • Help with apache mod_perlDecember 10

    I'm in the process of teaching myself perl, and I've also just set up a server. I'd like to combine my efforts .    I'd like to know how to set up apache with mod_perl. I gather it will probably need some sort of recompilation? I also don't see a mod

  • V9 + Apache + mod_perl = ???November 30

    Anyone know how to enable mod_perl on the Apache that is included with Solaris/X96 V9? It looks like mod_perl is included, but I can't quite figure out how to enable it. I see the line: AddModule mod_perl.c In httpd.conf, but I don't see a correspond

  • Compiling Apache with PERL module on Solaris 8November 30

    Hi there, After the Richard's reply, I found the Apache sources on the intallation CD 2/2. And after a while I successful compile the apache WITH ITS STANDARD modules with the following command: $ ./configure --prefix=/usr/apache \ --enable-module=mo

  • Apache Seg FaultNovember 30

    I have an apache 1.3 server that is intermittently seg faulting. The setup is 32 bit RHEL 5.2 Apache/mod_perl, Apache::DBI, Oracle 10.2.0.2 Server, Oracle 10.2.0.4 instant client. This does not happen when using the 10.1.0.5 instant client. The core

  • Error while trying SSL on OHSOctober 11

    I'm getting "Init: SSL call to NZ function nzos_OpenWallet failed with error 29248" error in log file HTTP_Server~1 while starting OHS (using opmnctl startall). I created a Wallet with auto login option checked. I was able to create certificate

  • Unable to run postclone script in Web tierOctober 11

    Hi guys, I am trying to clone an existing Oracle Ebsuiness Suite 12.1.3 environment. Now I am trying to execute command: perl adcfgclone.pl appsTier in the Web tier node, but I am getting next error message: Executing script in InstantiateFile: /oram

  • Error "RC-50013" in ApplyAppsTechStack for Step 3 of 5 (53% and 92%) R12 installationOctober 11

    I've tried to install R12 on Windows Server 2003 32-bit as well as 2008 64-bit. Both instances generated seemed to hang at Step 3 of 5: 53% total and 92% (Registering Tech Stack) I'm using Cygwin and Visual Studio 8 that were configured based on this

  • Can the WLPI be used for a perl web siteOctober 11

    We have a client, which has a perl(Apache/mod_perl) based web site. Cutomers submit orders on the web site and right now there is an order-processing system, but the client is looking for workflow/process product which will ease with all this order p

  • Autoconfig in Application Tier went errorOctober 11

    Hi, While running Autoconfig in Application after clone it got error, Please advise.. DB Version : 11.1.0.7 Apps Version : 12.1.1 Please find the below error message.. Starting AutoConfig at Fri Jan  4 11:24:35 2013 Using adconfig.pl version 120.26 *

  • Error while Installing R12.1.1 on Windows 2003 Enterprise EditionOctober 11

    Dear All, I am installing R12.1.1 on Windows 2003 Enterprise Edition Server. I am using the media source that i have downloaded from Oracle Edelivery. I have done a MD5Sum check on the dowloaded files based the MD5SUM Check details given in site. (No

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 14 q. 0.401 s.