Home > Default > Error in model node binding

Error in model node binding

November 30Hits:0
Advertisement
Hi All,
I am facing some strange problem of model node binding.I have bound the model node to a model class.I am using Wizard to generate this model node binding.
To deploy this DC I am using NWDI .But the activation step is failing because of some build errors.moreover these build errors are not appearing at design time!!
CBS error log is as below :
[Error]   com.bhc.nextgen.sales.suppcatapp.SuppCatLookupComp --> ContextModelNode Zrfc_Sd_Quote_Supplier_Search_Input [modelClass]: The context model node has not been bound to a model class (Hint: A Context model node has to be bound to a model class or mapped to a model node of another controller.)
Dose anyone know how to solve this?
Thanks,
Kanchan

Answers

Hi
I'm not sure if I understand you completely but instead of manually creating a model node which you bind to your model you could - in Diagram View - right click on the Data link and drag and drop your model from right to left and it will automatically create the needed model class references etc.
Br
Göran

Read other 3 answers

Tags:

Related Articles

  • Error in model node bindingNovember 30

    Hi All, I am facing some strange problem of model node binding.I have bound the model node to a model class.I am using Wizard to generate this model node binding. To deploy this DC I am using NWDI .But the activation step is failing because of some b

  • Activation error : context model node has not been bound to a model classNovember 30

    Hi All, I have DC project, which i am able to run without error, But when i try to activate this DC project, I am getting below error in activation log : Please help me out, It's very urgent... [wdgen] [Info]    Generating packages/com/ltli/crtmachin

  • Accessing model node with cardianlity 1 to 1 throwing errorOctober 11

    Hello All, I'm try ing to set values to a model node in the request for a mass update. in teh model nodes, one of the model node is mandatory with 1:1 cardinality. i cannot call the currentElement() nor the create and addelement both throwint the sam

  • Node Binding ErrorNovember 30

    Hello, I am on EP7.0 ERP05 NW04s and trying to modify the ESS Address applicaion to point to a custom Function Module ,I changed the Model Bindings for that matter but when I try to execute the application I get the following error during runtime: co

  • How to bindi a UI element to 2 model nodes different in the same viewOctober 11

    I want to know how I can bind a set of inputfields, in a form view, to 2 different model nodes ? <u>example:</u> Im working with 2 adaptional RFC, both working, in my Custom Context. Ztest_Search Ztest_Update In my ResultView I have 2 Model no

  • Error while sorting the model node tableOctober 11

    hi if(firstTime)                  view.nowCreateAllCustomExtensionFields();            IWDTable tab= (IWDTable)view.getElement("tbl_car");            wdContext.currentContextElement().setCarTableSorter(new TableSorter(tab,wdThis.wdGetCarTableSor

  • Error 500: Model binding context not initializedOctober 11

    I have created a JHeadStart Bc4J application in JDeveoper 10g and moved it WebSphere 6. I have moved all the required binary libraries to the lib/ext directory of the WebSphere AppServer. JSP and HTML pages are being displayed correctly but whenever

  • Binding model nodes - seeming repetition?November 30

    Hello, When creating a WD app using Adaptive RFC Model (or any model I assume), it is necessary to create a data link between the Model and Component Controller.  Visually, the fields of the nodes of the Model and the fields of the model nodes of the

  • Creation of new element in Model NodeOctober 11

    Dear All, I am facing one problem, I have two  model node. I want to copy one model node to other model node.while copying its giving error saying the you can bind the element, coz target node doesn't have valid parent. Pl don't suggest me work on Va

  • How to addRecord in Web Dynpro to Model node (Entity Service ref)November 30

    Hi, 1) I create Entity Service in CAF and try to write web dynpro Table UI for it. 2) is it possible with using Model Node? or I MUST use Value Node - Table must have possibilities for Add, Edit and Delete records. Now I can edit, and delete records,

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 15 q. 1.178 s.