Home > Default > Error deploying Web Service in Oracle 10g AS (10.1.3.0)

Error deploying Web Service in Oracle 10g AS (10.1.3.0)

October 11Hits:4
Advertisement
When deploying a secured web service from Oracle EM 10.1.3 i'm getting the following exception
"Failed in uploading archive. Invalid archive file: Invalid value: AES-256"
The same web service (.ear) file is getting uploaded without exception when deploying directly from Oracle JDeveloper 10.1.3.0

Answers

The problem solved when creating a webservice ear file with the keystore generated in the machine where the application server is installed.
We created a secure web service (in client machineA) with public/private key encryption (AES 256) and tried deploying it in an application server instance (Server machineA). Doing this gives the following expection (when deploying the ear file through EM)
"Failed in uploading archive. Invalid archive file: Invalid value: AES-256"
We solved the problem by creating a keystore file in the application server instance machine (instead of doing it in client machine) and used the same keystore file to create the ear file which got deployed succesfully.
Thanks for your help

Read other 3 answers

Tags:

Related Articles

  • Error deploying Web Service in Oracle 10g AS (10.1.3.0)October 11

    When deploying a secured web service from Oracle EM 10.1.3 i'm getting the following exception "Failed in uploading archive. Invalid archive file: Invalid value: AES-256" The same web service (.ear) file is getting uploaded without exception whe

  • How to Create and Deploy Web Services Using Oracle 9i JDeveloperNovember 30

    Hi, My Question is how to create and deploy Web Services using Oracle 9i JDeveloper.Anybody please give me a detailed Reply.Please Reply to [email protected] Hopr to Hear From you, Regards, G SreekumarYou could use datasources. You should do this in

  • Error deploying web service generated by JDeveloper 10.1.3October 11

    Hi, I am trying to publish a package as a Document/literal web service using JDeveloper10.1.3. When I deploy the .ear file so generated to Oracle Application Server v10.1.2.0.0, I get the following error: Deployment failed: Nested exception Resolutio

  • Consuming Axis web service from Oracle 10g databaseOctober 11

    Greetings, I have a working web service that I want my Oracle 10.2 database to consume. I've taken the wsdl file from the web service and run it through Apache Axis' wsdl2java function, thus creating the Java client stubs required. Is it possible to:

  • Create web service in oracle 10g r2November 30

    Hi guys, I am trying to expose a package function as a web service in the database (10g r2) for outside clients to call on. I saw a good example on the following url in 11g http://www.oracle-base.com/articles/11g/NativeOracleXmlDbWebServices_11gR1.ph

  • Database Web Services with Oracle 10gNovember 30

    Forgive my lack of knowledge on this issue, but we are still researching our options and we have very little experience with these new technologies. We have been using Oracle Database server for years and we are looking now into integrating or applic

  • Deploying Web services on Oracle Application ServerNovember 30

    Hi, I am not sure whether this is the forum where I should post this question. I am trying to deploy a webservice on Oracle iAS version1.0.0. But when I navigate to Oracle CRM Administrator(responsibility)-->Integration-->services I get a message te

  • Error deploying web service built in JDeveloper to GlassFishNovember 30

    Hi everyone, I tried posting this question to GlassFish forum at java.net but received no response, so I'll give it a shot here... I have built a web service from WSDL using JDeveloper (11.1.1.0.5). I tested it succesfully in JDeveloper's embeded Web

  • Calling a web service from Oracle 10g formsOctober 11

    Hi Everybody I want to send SMS from my 10g forms.... I searched for the topic and I got the following link "http://www.oracle.com/technology/products/forms/htdocs/10gr2/howto/webservicefromforms/ws_10_1_3_from_forms.html" Now I have downloaded

  • Error deploying Web Service after upgrading from WL 7.0 No Service Pack to SP5October 11

    Hello I have problem using HttpServletResposneWrapper with a ServletFilter in WLW 7.0 SP5. When I apply the filter to JWS file in Development Mode, following Exception is thrown when I access a JWS. ===================================================

Copyright (C) 2019 wisumpire.com, All Rights Reserved. webmaster#wisumpire.com 14 q. 1.015 s.